it.ucsf.edu

Security Update:CRITICAL, HIGH, and Moderate Security Updates Released for Firefox, Firefox ESR and Thunderbird

Status Type

Security Update

Date and Time

Tuesday, March 7, 2017 - 16:52

Reason

 

Security Update

Impact

Firefox, Firefox ESR and Thunderbird Users

 

WHAT HAPPENED?
Mozilla released security updates to address several vulnerabilities, CRITICAL, HIGH, and Moderate in Firefox, Firefox ESR and Thunderbird.

Advanced Users: For a complete description of the security enhancement and affected software refer to:


AVAILABLE UPDATES FOR:

  • Firefox 51 and below
  • Firefox ESR 45.7 and below
  • Thunderbird 45.7 and below


WHAT'S THE PROBLEM?
Exploitation of the vulnerability may allow an attacker to take control of your computer.


HOW DO I PROTECT MY COMPUTER?
Update your software

  1. If you are supported by ITFS or have different IT support, no action on your part is required.
  2. If you do not have IT support or they do not support your computer:


RELATED LINKS